Hello USA! Servers now available in US East and US West!

Valheim

Incompatible version on Valheim server

If your Valheim client is not allowing you to connect to your server with the error "Incompatible version" it means the versions for your client and server are mismatched. We try to keep servers up to date, but Valheim is a brand new game on our platform so currently if you're struggling to play the game please contact our team on Discord. We also recommend enabling automatic updates for Steam so your client will stay up to date.